EverTrue Platform - Platform Slowness/Loading Issues
Incident Report for EverTrue
Resolved
This incident has been resolved. If you experience any issues, please reach out to genius@evertrue.com
Posted Dec 19, 2023 - 11:05 EST
Monitoring
A fix has been implemented and we are monitoring the results. If you experience any issues, please reach out to genius@evertrue.com
Posted Dec 18, 2023 - 14:16 EST
Identified
We have identified the issue causing some platform slowness/loading issues for some users. We are taking steps to resolve and are monitoring results. Please reach out to genius@evertrue.com if you have any questions.
Posted Dec 18, 2023 - 11:32 EST
Investigating
We are currently investigating an issue causing some EverTrue platform users to experience loading issues and/or general platform slowness. Our team is working to identify and resolve as quickly as possible. If you have any questions, please reach out to genius@evertrue.com
Posted Dec 18, 2023 - 09:39 EST
This incident affected: EverTrue.