This incident has been resolved. If you have any questions or experience any email campaign deliverability issues, please reach out to support@thankview.com.
Posted Sep 03, 2025 - 16:13 EDT
Monitoring
A fix has been implemented and we are monitoring the results. All affected campaigns should be resolved. Please reach out to support@thankview.com if you have any questions.
Posted Sep 03, 2025 - 15:00 EDT
Identified
We have identified the issue and are implementing a fix. If you have any questions, please reach out to support@thankview.com
Posted Sep 03, 2025 - 14:44 EDT
Investigating
We are currently investigating an issue that is preventing some email campaigns from being sent in the ThankView platform. At this time, we ask that you please do not attempt to send email campaigns with 500 or more recipients as we troubleshoot the issue. We apologize for the inconvenience and are working to resolve as quickly as possible. If you have any questions, please reach out to support@thankview.com
Posted Sep 03, 2025 - 13:09 EDT
This incident affected: ThankView (Email Delivery).