EverTrue Imports - Failures due to a critical error

Incident Report for EverTrue

Resolved

This incident has been resolved.
Posted Jan 14, 2026 - 15:22 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jan 13, 2026 - 16:22 EST

Investigating

We are investigating an issue that is causing some automated imports to fail with this error code:
Critical Error(s) Occurred:Error: Sorry, we ran into an internal error. Please try your import again.

We apologize for the inconvenience and are working to resolve as quickly as possible. If you have any questions, please reach out to genius@evertrue.com
Posted Jan 13, 2026 - 09:46 EST
This incident affected: EverTrue (Imports).