EverTrue iOS - mobile application not functioning as expected

Incident Report for EverTrue

Resolved

This incident has been resolved. Please reach out to genius@evertrue.com if you have any questions.
Posted Apr 10, 2026 - 09:51 EDT

Update

We are continuing to monitor for any further issues.
Posted Apr 10, 2026 - 09:34 EDT

Monitoring

A fix has been implemented and we are monitoring the results. Please reach out to genius@evertrue.com if you continue to experience any issues with the app.
Posted Apr 10, 2026 - 09:34 EDT

Update

We are continuing to work on a fix for this issue.
Posted Apr 10, 2026 - 09:00 EDT

Identified

We have identified an issue that is preventing the EverTrue iOS from functioning as expected. We are working to resolve as quickly as possible. Please reach out to genius@evertrue.com if you have any questions. Please note android and web are not affected.
Posted Apr 10, 2026 - 08:48 EDT
This incident affected: EverTrue (iOS App).