EVERTRUE (SIGNAL EMAIL): error on email sends

Incident Report for EverTrue

Resolved

This incident has been resolved! If already logged in, please perform a hard refresh to ensure the fix is applied to your session (command+shift+R on Mac, CTRL + F5 on PC)
Posted Feb 25, 2026 - 10:13 EST

Investigating

We are currently investigating an issue that is causing errors when sending emails through SIgnal. We apologize for the inconvenience and are working to resolve the issue as quickly as possible. If you have any questions, please reach out to support@thankview.com.
Posted Feb 25, 2026 - 09:33 EST
This incident affected: EverTrue (Signal Email).