ThankView Platform - Platform Loading Issues

Incident Report for EverTrue

Resolved

This incident has been resolved. Please reach out to support@thankview.com if you experience any issues.
Posted Aug 14, 2025 - 20:28 EDT

Monitoring

The issue has been identified, a fix has been implemented and we are currently monitoring the ThankView systems. Full functionality should be restored for all users. If you have any questions please reach out to support@thankview.com
Posted Aug 14, 2025 - 19:29 EDT

Investigating

We are investigating an issue that is causing some users to be unable to load platform pages, such as the login page, landing page builder, and others. We apologize for the inconvenience and are working to resolve as quickly as possible, if you have any questions, please reach out to support@thankview.com
Posted Aug 14, 2025 - 18:33 EDT
This incident affected: ThankView (Web Application).