EverTrue Imports - Files Failing Pre-Processing

Incident Report for EverTrue

Resolved

This incident has been resolved.
Posted Mar 06, 2026 - 18:09 EST

Monitoring

A fix has been implemented. Previously stalled imports are now being processed. Due to the current backlog, processing may take some time, but we will continue monitoring progress.
Posted Mar 05, 2026 - 13:31 EST

Update

We are investigating an issue that is causing some files to fail during pre-processing. We apologize for the issue and are working to resolve as quickly as possible. If you have any questions please reach out to genius@evertrue.com.
Posted Mar 04, 2026 - 09:21 EST

Update

We are investigating an issue that is causing Assignments files to fail at pre-processing. Other file types are not affected. If you have any questions, please reach out to genius@evertrue.com.
Posted Mar 04, 2026 - 09:18 EST

Investigating

We are investigating an issue that is causing some files to fail during pre-processing. We apologize for the issue and are working to resolve as quickly as possible. If you have any questions please reach out to genius@evertrue.com.
Posted Mar 04, 2026 - 08:22 EST
This incident affected: EverTrue (Imports).