EverTrue Imports - Temporary import delays for data sync customers

Incident Report for EverTrue

Resolved

This incident has been resolved! All Data Sync customers have had their syncs caught up and are syncing normally.
Posted Jan 26, 2026 - 10:29 EST

Identified

Blackbaud is currently experiencing API service degradation so some Raiser's Edge customers may see a temporary delay in the data sync from Raisers Edge to EverTrue, impacting Constituent and Gift data. Once the service issue is resolved on Blackbaud's end, the Data Sync will automatically catch up any missed data.

Blackbaud updates can be viewed here - https://status.blackbaud.com/
Posted Jan 23, 2026 - 12:07 EST
This incident affected: EverTrue (Imports).