EverTrue: Signal Email connection errors

Incident Report for EverTrue

Resolved

This incident has been resolved!
Posted May 11, 2026 - 13:18 EDT

Monitoring

A fix has been implemented and we are monitoring results. Please perform a hard refresh (command+shift+R on Mac, CTRL + F5 on PC) and then try re-connecting your email accounts
Posted May 11, 2026 - 11:42 EDT

Investigating

We are currently investigating an issue that is preventing users from being able to connect their email accounts in Signal. We apologize for the inconvenience and are working to resolve the issue as quickly as possible. If you have any questions, please reach out to genius@evertrue.com.
Posted May 11, 2026 - 10:38 EDT
This incident affected: EverTrue (Signal Email).