EverTrue Platform - Constituent Profile loading issues

Incident Report for EverTrue

Resolved

This incident has been resolved.
Posted Jul 08, 2026 - 12:30 EDT

Investigating

We are currently investigating an issue that is preventing some constituent records from loading in the EverTrue platform. Some users may also be receiving "Ai email generation failed" errors on profiles. We are working to resolve as quickly as possible and apologize for any inconvenience this may cause.
Posted Jul 08, 2026 - 12:15 EDT
This incident affected: EverTrue (Application).